LiveChat support is not operational
Incident Report for Wide Angle Analytics
Resolved
Issue resolved :)
Posted Jul 20, 2022 - 11:36 CEST
Monitoring
Our LiveChat provider, Sendinblue, is facing a technical issue. As a result, the in-app chat is currently unavailable.

We are always an email away if you need us.

Apologies for any inconvenience.
Posted Jul 20, 2022 - 10:11 CEST
This incident affected: Website.