Mail delivery issue
Incident Report for Wide Angle Analytics
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 14:08 CEST
Update
Email deliverability is now fixed. We identified a window of service degradation between 9:00 and 14:00 Berlin time.

Connectivity issues with the email API caused the problem.
Posted Jul 13, 2022 - 14:08 CEST
Identified
The email delivery system is currently not working correctly. This affects the ability to log in and register.
Posted Jul 13, 2022 - 14:01 CEST
This incident affected: Website.